Community X.

Connect with other creators, share ideas, give feedback and get the latest product updates.

Jul 26
Edited: Jul 26

A few things just don't work

I love the idea of editorX and I know one day it will be super sharp and I know it's still in Beta, but there are a number of things that don't work or have odd behaviours.


1 Anchors. Forget 'em. I spent two days tearing my hair out trying to get these to work.

They don't position correctly in preview and rarely work at all once published. I gather this is being looked into by the developers, but as it stands it renders the platform fairly useless if you need to guide users through your homepage as is fairly standard these days.


2. on publishing, I keep getting odd page names like 'blank' (which gives a blank page unless I hit return again) or 'website 1-1 -2'. I have to go to SEO settings for each page and manually change the page name...


3 Social bar fine in preview but nowhere to be seen when published.


4. something has gone a bit wrong with my homepage with the bottom of the page kind of disappearing on laptop breakpoint but giving me a huge footer when published that looks different from the preview version (see screenshot). there should be a 30px pad at the bottom but its kinda cropped out. When published the footer takes up the grey area below as well as its own space giving a large near-empty footer.







Jul 26

Sometimes I suspect about them using an hidden different Editor X where it seems to do not have any issues at all and design all the templates.

Editor X

Design your boldest creations.