Community X.

Connect with other creators, share ideas, give feedback and get the latest product updates.

Dec 29, 2020

An issue with the Content Manager.

Hi there.

I wanted to create a content-driven website where users can upload images and then view them. For this, I added a Repeater and linked it to a Content Manager with some pre-uploaded images from my computer. Then I added an upload button and linked it to my Content Manager and set all the permissions to 'Anyone', so that anyone can add and view the images. However, instead of adding new images, it's 'replacing' the images that were already uploaded by me with new ones.


Here are some things that could help:

▪️The Content Manager Permissions were set to 'Custom Permissions' and all Custom Permissions were set to 'Anyone'. ▪️The Dataset Mode has been set to 'Read & Write'



For those who didn’t understand what I was talking about, here's an example.


▪️ There are 2 images on a website, named Image X and Image Y. (Fig. 1)


Fig. 1

▪️ A user wants to add a third image, named Image Z. (Fig. 2)


Fig. 2

▪️ For this, the user uploads Image Z and presses Submit. (Fig. 3)


Fig. 3

▪️ The actual result should be this:

Image X, Image Y, and Image Z. (Fig. 4)


Fig. 4

BUT...


▪️ The result turns out to be THIS:

Image Z and Image Y. (Fig. 5)


Fig. 5


WHY DOES THIS HAPPEN?


This should not happen. I want Image Z to be ADDED next to Image X and Image Y and NOT REPLACE Image X with Image Z.

I've created a DEMO Site to demonstrate this very problem. Here's the link:

https://prezapd.editorx.io/demo


When you upload an Image and click on Submit, your image should come to the right of Image Y and the total number of images visible on the screen should be 3. But instead of that, your image comes to the left of Image Y and Image X GETS REPLACED WITH THE NEW IMAGE THAT YOU UPLOAD.

Try it out yourself.



CAN SOMEBODY PLEASE HELP ME WITH IT?


Can somebody from the EditorX Team, or somebody from the forum look into this and let me know the solution? I'd be really grateful if you could look into this and tell me what to do so the images get ADDED and NOT REPLACED. For if I don't find a solution to this, I won’t be able to create the website that I want to create. I've spent a lot time typing this post and creating the Demo Site, so that people can fully understand the problem and help me resolve it.


Thank you for reading this entire post and thank you in advance if you’re trying to find a solution for it. Please let me know what can be done ASAP! (:

Dec 29, 2020

why not set permission to form submission? As I understand you want users only be able to add pictures, not change.

Dec 30, 2020

Thanks @jeroen ! I did what you said but still couldn’t resolve the issue. Then I set the custom permissions to this:

And I was finally able to resolve the issue. Thank you!

Editor X

Design your boldest creations.